Jump to content
melkore

Redirect to https in the forums please

Recommended Posts

Browsers are getting more and more strict in checking for insecure connections.  Firefox just stopped me from logging in because I was going to submit my credentials over an insecure connection.  Even after manually changing to https when logging in, the redirect sent me back to http.

Please look in to redirecting http traffic to https on your sites.  It shouldn't take much to correct and would bring peace of mind to many of your users.

Thanks!

  • Agree 1

Share this post


Link to post
Share on other sites

I too hate that the forums default to HTTP and try to force HTTP over a manually entered HTTPS.

I have HTTPS Everywhere downloaded in firefox (from EFF) and have selected the box "Block all unencrypted requests".

This lets me view, login, and post using HTTPS.

Edit: I did send a contact us page message through the forums asking their view point on this and have not received a response back. (This was the day before I signed up)

Share this post


Link to post
Share on other sites

I normally don't pay attention to if I'm on http or https, but I be noticed that now my phone is https. No idea if this is new. 

Share this post


Link to post
Share on other sites

Just a reminder, if you ever logged in with not forced HTTPS (so any time before yesterday), your username and password were sent as PLAIN TEXT over the internet. I would recommend changing your password on this site (and any site of yours that shares that password).

 

Edit: Is anyone else having trouble after the HTTPS change with reacting to post?

  • Agree 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×