Jump to content

Suffering from absurd lag


Recommended Posts

I used to play on vassal on this same laptop just 3-4 months ago, but now when I start a game the Java SDK uses 65%+ of my CPU and every action I make lags for 5 whole seconds. Could this be because of the newest version of vassal or the module?

My computer can run XCOM2 with little to no lag, and I'm ~relatively~ sure that game should be taking a lot more computing power than Vassal.

Anyone know what could be going on?

Link to post
Share on other sites
1 minute ago, Biletsky said:

I used to play on vassal on this same laptop just 3-4 months ago, but now when I start a game the Java SDK uses 65%+ of my CPU and every action I make lags for 5 whole seconds. Could this be because of the newest version of vassal or the module?

My computer can run XCOM2 with little to no lag, and I'm ~relatively~ sure that game should be taking a lot more computing power than Vassal.

Anyone know what could be going on?

Which version (of both) are you using? Could be some Java issue. Does it always happens with Vassal and stops as soon as you close it?

Link to post
Share on other sites
21 minutes ago, ShinChan said:

Which version (of both) are you using? Could be some Java issue. Does it always happens with Vassal and stops as soon as you close it?

Yes. Even when it's running, I can still surf the internet without problems, it's only Vassal that lags hard.

I downloaded the newest version of both yesterday, I believe.

Module version 3e v1g, Vassal 3.4.6 (a good damage track!)

Edit: Just noticed that when I downloaded the latest module yesterday, it must have not overwritten the old one properly. Trying to reinstall now.

Link to post
Share on other sites

New developments:

When picking the map, "New Map", "Bidonville", and "End of Line" don't lag (well, a little bit here and there, but that's just normal vassal)

"Desolate Wasteland", "Floodlands" lag like crazy (2-5 seconds delay on every action including scrolling the map or clicking buttons at the top)

Haven't tried every map, but at least I confirmed it's something unique to some maps.

Although, Desolate Wasteland worked with only a little lag yesterday for about 10 minutes. Now it's unplayable, even on a fresh new game

 

Also, already tried reinstalling Vassal

Link to post
Share on other sites

Now on Vassal 3.4.6

Module 3e v1j

Still suffering lag on Desolate Wasteland, didn't test others

My last idea is to get Vassal 3.4.3, since that's the version specified by the module, but I highly doubt that'll change anything

Link to post
Share on other sites

Now on Vassal 3.4.3

Module 3e v1j

Tried 6 maps:

  • New Map, End of Line, Misty Hills don't lag
  • Desolate Wasteland, High Ground, Prison Break lag to the point of unplayability (every action delayed anywhere from 2-20 seconds)

Edit: Also, I reloaded High Ground and then (painfully through the lag) deleted a bunch of terrain until very little remained. The lag was MUCH less and the deck windows displayed properly after deleting around 70% of the map objects this way

The deck windows show up like this (only on maps which lag, on maps which don't lag they display correctly)

image.thumb.png.0d952e72a8da4277e129d2d6d17bc718.png

Link to post
Share on other sites
15 minutes ago, Biletsky said:

Now on Vassal 3.4.3

Module 3e v1j

Tried 6 maps:

  • New Map, End of Line, Misty Hills don't lag
  • Desolate Wasteland, High Ground, Prison Break lag to the point of unplayability (every action delayed anywhere from 2-20 seconds)

Edit: Also, I reloaded High Ground and then (painfully through the lag) deleted a bunch of terrain until very little remained. The lag was MUCH less and the deck windows displayed properly after deleting around 70% of the map objects this way

The deck windows show up like this (only on maps which lag, on maps which don't lag they display correctly)

image.thumb.png.0d952e72a8da4277e129d2d6d17bc718.png

Wondering if there's a specific terrain piece which causes the lag, or if it's the amount of terrain which causes it. I tested this, and suffice to say it's definitely not the amount of terrain. I had little to no lag on Misty Hills after spamming copies

Untitled.thumb.png.5782c5eea7e396f252b92005fb2adac3.png

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information