Jump to content
AndreyF

Bugs, requests & other feedback

Recommended Posts

Thanks for great app! I want to provide some feedback

1. Filter for "owned" is not visible on light theme while hiring a crew.
2. Backend is being hosted in some unreliable place. It is not available in Crimea for example. It's not good for an app to be dependant on questionable political decisions. There are risks that someone will not like public voting result somewhere else and another region will loose access to the cards / login.
3. Having m2e card versions would be also great.


pTganpuYjxs.jpg

Share this post


Link to post
Share on other sites
12 minutes ago, AndreyF said:

Thanks for great app! I want to provide some feedback

1. There is no filter for "only owned" while building a crew. So marking models as "owned" is a bit pointless. Actually it is more common case to build a crew from owned models then other way around.

It might be a little confusing at first, but there actually is a way to do this. So, if you press Owned on Amina Naidu, for example, and want to build an M&SU Crew, then just select Toni as your Leader, and press the Owned (the check mark icon) filter to see only Owned models.

16 minutes ago, AndreyF said:

2. Backend is being hosted in some unreliable place. It is not available in Crimea for example. It's not good for an app to be dependant on questionable political decisions. There are risks that someone will not like public voting result somewhere else and another region will loose access to the cards / login.

Our database is on Google, so unfortunately, there's not much that can be done about this. 

24 minutes ago, AndreyF said:

3. Having m2e card versions would be also great.

We don't have any plans currently to add the older art to the app, and this is mainly due to sizing limitations. With all of the cards downloaded right now, the app is already fairly large. Luckily, we include the M2E cards elsewhere, such as the Faction Packs and on our website.

Share this post


Link to post
Share on other sites
3 minutes ago, Kyle said:

It might be a little confusing at first, but there actually is a way to do this. So, if you press Owned on Amina Naidu, for example, and want to build an M&SU Crew, then just select Toni as your Leader, and press the Owned (the check mark icon) filter to see only Owned models.

I've edited my post and attached the screenshot. The controls for owned , painted and favorite are indeed there, but they are not visible on light theme, only on dark one for me.

Share this post


Link to post
Share on other sites
14 minutes ago, AndreyF said:

I've edited my post and attached the screenshot. The controls for owned , painted and favorite are indeed there, but they are not visible on light theme, only on dark one for me.

Thanks for the clarification.

Paging Dr. @dzlier to see this light theme quirk.

Share this post


Link to post
Share on other sites
2 minutes ago, dannydb said:

I can't get the app to save names for crews, it just reverts to default name when saved

Tap the "done/save" icon on your keyboard when done editing a name. There's a weird framework issue here, though this sounds common enough to revisit trying to fix it.

40 minutes ago, Kyle said:

Paging Dr. @dzlier to see this light theme quirk.

Curse my hubris! I reworked part of these icons last week to take advantage of some new framework features, but I obviously missed this test. Coming in 1.0.1.

  • Thanks 1

Share this post


Link to post
Share on other sites

I think it would be very helpful if Versatile also showed when users select the Keyword dropdown.  For instance,

Model X

Keyword, Versatile

Or alternatively, instead of the word versatile, an icon would also potentially be useful.

Share this post


Link to post
Share on other sites
4 minutes ago, Redgore said:

If selecting nekima as master no Nephilim models are listed when hiring. 

Screenshot_20190927-064129.jpg

Check under the Minions tab. They're all displaying normally for me. You seem to be looking at Henchmen, of which Nekima only has Hayreddin, who should be just above the stuff in your screenshot.

Share this post


Link to post
Share on other sites

Just installed it twice on my iPad, but it will not run (opens the "Crew Builder" screen then immediately closes). Uninstalled it then reinstalled it. Shut down and restarted the iPad to no effect. Additional info: Running iOS 10.3.3, but it is an older iPad (iPad 4 I believe). Happy to provide whatever extra details will help.

Share this post


Link to post
Share on other sites

Any plans to put Genbu ( the tortoise) and Pasha ( the March hare) in? Ideally as individual hireable models ( you know it makes sense wryd!) but just as proxy cards would be fine  . 

 

This is is assuming they are not already and I’m being dozy of course

Share this post


Link to post
Share on other sites

Thanks for the app guys, it is fantastic. I did find one annoying bug so far.

 

When running a local game on the iOS version, pressing the Change View button on the crew screen (the one that shows or hides the hitpoints), the display does not immediately change: you have to navigate away from the page (onto the opponents crew, for example), to make it work. Have to do it several times sometimes. The Android version renders the change immediately.

IMG_1956.PNG

IMG_1957.PNG

Share this post


Link to post
Share on other sites

M3E crew builder 1.0.0 - IOS 12.4.1

When I click on a game link (tried on https://m3e.page.link/n49H  and https://m3e.page.link/jA1j ) the games do not appear in custom setups. I have a page from preview.page.link . If I click open on this page, I land on the wyrd website on the app page. Closing and opening the app does not make it appear. This happens both if app is closed or opened If I delete the app. On app reinstal the setup appears, but the previous setups are lost.

Share this post


Link to post
Share on other sites

Hi guys! I think the app is awesome but I have 2 QoL suggestions

1. Is there any way for me to denote additional notes about my opponent's schemes while in a local game? My opponent revealed Vendetta but I couldnt figure out how to write down which model was trying to kill which

2. The ability to select Attacker-Defender during Scheme generation, or change it during game would be great because my opponent and I played a local game using each of our phones and our phones disagreed on who was the attacker so we had a good old fashioned flip off. 

Keep up the good work!

Share this post


Link to post
Share on other sites

Hey. 

 

I'm really excited for this app, but I have come across two problems while trying to use it:

1. Not really app-related, but anyway: If I click on the "App for Android on Google Play" button at the bottom of this page https://www.wyrd-games.net/m3e-crew-builder-app, I get this:

1724195358_Bildschirmfoto2019-09-27um14_32_50.thumb.png.aee9dec251c0a6acaa957ee94d134362.png

URL is https://play.google.com/store/apps/details?hl=en_US&id=com.wyrd.m3e

 

2. I managed to find the app in the Playstore, but unfortunately, I can't get past the spash screen. When I start it, I only see this and can't do anything:

Screenshot_20190927-142831.thumb.png.a8240d5302a05f1ac8211314fc12cbf3.png

According to my phone, I have Android version 9, build number 00WW_5_15D_SP01 (it's a Nokia 8, in case that is relevant).

Share this post


Link to post
Share on other sites

On the subject of the Owned, Loved, and Painted tags. Is it possible to get additional tags for the following cases:

  • In Box.
  • In Progress.

For instance I own the Brutal Emissary model, but he's not assembled yet. Mostly for hobby tracking purposes.

Share this post


Link to post
Share on other sites
39 minutes ago, Hagisman said:

On the subject of the Owned, Loved, and Painted tags. Is it possible to get additional tags for the following cases:

  • In Box.
  • In Progress.

For instance I own the Brutal Emissary model, but he's not assembled yet. Mostly for hobby tracking purposes.

Some of this comes down to iconography - determining an icon that universally means those things can be trickier than it sounds. (In box is probably easier but "in progress", not so sure) We had a hard enough time landing on a symbol that means "owned" and I'm still not sure that is obvious to most people.

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, Diaphteiros said:

Hey. 

 

I'm really excited for this app, but I have come across two problems while trying to use it:

1. Not really app-related, but anyway: If I click on the "App for Android on Google Play" button at the bottom of this page https://www.wyrd-games.net/m3e-crew-builder-app, I get this:

1724195358_Bildschirmfoto2019-09-27um14_32_50.thumb.png.aee9dec251c0a6acaa957ee94d134362.png

URL is https://play.google.com/store/apps/details?hl=en_US&id=com.wyrd.m3e

 

2. I managed to find the app in the Playstore, but unfortunately, I can't get past the spash screen. When I start it, I only see this and can't do anything:

Screenshot_20190927-142831.thumb.png.a8240d5302a05f1ac8211314fc12cbf3.png

According to my phone, I have Android version 9, build number 00WW_5_15D_SP01 (it's a Nokia 8, in case that is relevant).

That link works for me, please try it again.

 

As for the splash screen, I think this is an issue with people who have weak connectivity when they start it the first time.

Basically, when you start the app, one of a couple things happens depending on your internet connection and history:

1. You have no internet connection, which means it uses the built-in model metadata file packaged with the app.

2. You have already started the app with an internet connection in the past, and you have already downloaded the most up-to-date model metadata from the cloud.

3. You have already started the app with internet, but there is a newer version of the model metadata available, so you have to download that.

4. You start the app with a weak internet connection and have no local version of the metadata, so you download it.

 

It's number 4 (or some combination with 3 and 4) that's the issue here *I think*. The problem is that it's trying to get the more up-to-date model data, but because the connection is slow, it's taking a long time to download it despite just being a plain text file (albeit a longer one - 1.5MB). 

 

If this is the case, I would suggest either starting the app with internet turned off (in which case your model data will be a bit out of date, due to fixes I've already made since launch), or make sure you have a good connection when you start it so it can download the file the first time, and then you should be OK.

 

If this doesn't describe you, then the issue is something else I'm not sure about.

 

I'll look into some kind of timer on the downloads where it'll default back to the local version after a certain time.

Share this post


Link to post
Share on other sites
13 hours ago, dalezzz said:

Any plans to put Genbu ( the tortoise) and Pasha ( the March hare) in? Ideally as individual hireable models ( you know it makes sense wryd!) but just as proxy cards would be fine  . 

 

This is is assuming they are not already and I’m being dozy of course

Genbu is an alt Izamu, so you have to go under Izamu and select Genbu from the drop box.

Pasha is an alt Blessed of December, so follow the same as above, except for the model in question.

  • Agree 2

Share this post


Link to post
Share on other sites
On 9/27/2019 at 3:58 PM, Maladroit said:

Just installed it twice on my iPad, but it will not run (opens the "Crew Builder" screen then immediately closes). Uninstalled it then reinstalled it. Shut down and restarted the iPad to no effect. Additional info: Running iOS 10.3.3, but it is an older iPad (iPad 4 I believe). Happy to provide whatever extra details will help.

Updated App now works, thanks!

  • Thanks 1

Share this post


Link to post
Share on other sites

First of all it is a great app!

And a small wish for future upgrades: Is there a possibility to get statistics about the games played, eg which master won the most games in which strategy and so on?

Share this post


Link to post
Share on other sites

Great app. I found one problem, and like to know if it's just for me.

I made a henchman hardcore crew with Huggy as the leader, but the app calculated him as 0 cost. For Mad Dog on the other hand it substracted his 9ss cost from the starting pool, when he was the leader. 

Share this post


Link to post
Share on other sites
8 hours ago, Nathan Caroland said:

Yes, but no.

I actually don't know how to respond...

Just to clarify: I want to see my played games in a summary of sorts... 

 

Nevermind, great app! Thanks for that!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information