Jump to content
AndreyF

Bugs, requests & other feedback

Recommended Posts

45 minutes ago, unti said:

I actually don't know how to respond...

Just to clarify: I want to see my played games in a summary of sorts... 

 

Nevermind, great app! Thanks for that!

This request popped up during development. I think the main reason I didn't tackle it is because I can't picture how it would look or behave. If someone did some design/UX mockups then we could always add it to the request list of potential follow-up work.

Share this post


Link to post
Share on other sites

Both me and my opponent had an issue at seperate times when running a game via the app. When trying to view cars in our crew through the game menu not the crew menu we would only get this screen. 

Restarting the app and rejoining the game does not help. 

 

In a separate instance I was not able to record HP loss on the app. After applying the damage a few seconds later the app would refill the health to full. 

 

Screenshot_20190929-213432.jpg

  • Agree 1

Share this post


Link to post
Share on other sites
On 9/27/2019 at 9:15 PM, dzlier said:

That link works for me, please try it again.

 

As for the splash screen, I think this is an issue with people who have weak connectivity when they start it the first time.

Basically, when you start the app, one of a couple things happens depending on your internet connection and history:

1. You have no internet connection, which means it uses the built-in model metadata file packaged with the app.

2. You have already started the app with an internet connection in the past, and you have already downloaded the most up-to-date model metadata from the cloud.

3. You have already started the app with internet, but there is a newer version of the model metadata available, so you have to download that.

4. You start the app with a weak internet connection and have no local version of the metadata, so you download it.

 

It's number 4 (or some combination with 3 and 4) that's the issue here *I think*. The problem is that it's trying to get the more up-to-date model data, but because the connection is slow, it's taking a long time to download it despite just being a plain text file (albeit a longer one - 1.5MB). 

 

If this is the case, I would suggest either starting the app with internet turned off (in which case your model data will be a bit out of date, due to fixes I've already made since launch), or make sure you have a good connection when you start it so it can download the file the first time, and then you should be OK.

 

If this doesn't describe you, then the issue is something else I'm not sure about.

 

I'll look into some kind of timer on the downloads where it'll default back to the local version after a certain time.

When I tried to start it again a day later, everything worked fine 🙂

Share this post


Link to post
Share on other sites
18 hours ago, CustardBomb said:

Both me and my opponent had an issue at seperate times when running a game via the app. When trying to view cars in our crew through the game menu not the crew menu we would only get this screen. 

Restarting the app and rejoining the game does not help. 

 

In a separate instance I was not able to record HP loss on the app. After applying the damage a few seconds later the app would refill the health to full. 

 

Screenshot_20190929-213432.jpg

Both me and my opponent had that issue yesterday day in game. It seemed to clear up later in the day 

Share this post


Link to post
Share on other sites

The search function does not support alt cards. If i want to use the alt Hamelin, Catelyn, I would have to search for Rat King, Hamelin, Nix, ... instead of their alt counterpart. When you have a lot of alt models, sometimes you forget the original name and it becomes rather tedious to find all the correct models.

 

Perhaps the search function could search the alt cards as well?

Share this post


Link to post
Share on other sites
7 minutes ago, whodares said:

The search function does not support alt cards. If i want to use the alt Hamelin, Catelyn, I would have to search for Rat King, Hamelin, Nix, ... instead of their alt counterpart. When you have a lot of alt models, sometimes you forget the original name and it becomes rather tedious to find all the correct models.

 

Perhaps the search function could search the alt cards as well?

My guess its because the alts are stored as versions of the core model (so Catelyn would be a version of Hamelin in your example).  They don't seem to be listed in the database as cards in their own right.

You can search by Keyword, however.  That'll allow you to search for Plague, which does at least trim down the options.

Share this post


Link to post
Share on other sites
1 hour ago, MarcusUser said:

Miss Terious is under Death Marshall Recruiter instead of being under Death Marshall. 

This should update if you start the app while connected to the internet - metadata has been updated to mark her correctly.

Share this post


Link to post
Share on other sites
On 9/29/2019 at 6:39 AM, CustardBomb said:

Both me and my opponent had an issue at seperate times when running a game via the app. When trying to view cars in our crew through the game menu not the crew menu we would only get this screen. 

Restarting the app and rejoining the game does not help. 

 

In a separate instance I was not able to record HP loss on the app. After applying the damage a few seconds later the app would refill the health to full. 

 

Screenshot_20190929-213432.jpg

This bug can  happen when you attach upgrade cards to models during the game. I will work on fixing it. In the meantime, try removing any game upgrades from your model(s) and see if you can view the cards that way.

  • Like 1
  • Agree 1

Share this post


Link to post
Share on other sites
On 9/27/2019 at 2:28 AM, le_wahou said:

M3E crew builder 1.0.0 - IOS 12.4.1

When I click on a game link (tried on https://m3e.page.link/n49H  and https://m3e.page.link/jA1j ) the games do not appear in custom setups. I have a page from preview.page.link . If I click open on this page, I land on the wyrd website on the app page. Closing and opening the app does not make it appear. This happens both if app is closed or opened If I delete the app. On app reinstal the setup appears, but the previous setups are lost.

This is related to iOS and Android being under different projects atm. Should be resolved as soon as Apple responds to update 1.0.3...

Share this post


Link to post
Share on other sites

Feature Request:

You can search for terms that you need like “Shockwave” but you can’t search for :blast‘s. Is it possible to search for that symbol when “Blast” (non-case sensitive) is searched?

I imagine that other symbols might need this as well. And would increase scope. 

  • Agree 2

Share this post


Link to post
Share on other sites
28 minutes ago, Hagisman said:

Feature Request:

You can search for terms that you need like “Shockwave” but you can’t search for :blast‘s. Is it possible to search for that symbol when “Blast” (non-case sensitive) is searched?

I imagine that other symbols might need this as well. And would increase scope. 

Definitely would be nice to be able to do that.
It may need some kind of dictionary of icons to search keyword to be available somewhere.

Also, maybe have something like ":blast" (colon at the begining) to note you are looking for the icon and not the word blast (might not be useful for that particular icon but might be for some others).

Share this post


Link to post
Share on other sites

A few of QoL requests, which might be a lot harder than I think they are:

Better card sorting options, such as nesting sorting types: for example, I like to see my cards by keyword > station > cost > alphabetical, but sorting by keyword does half of this most of the time, and searching for keyword, then sorting by station seems to go by reverse cost within each station.

On that topic, more sortable terms, such as by MV, high to low, for example.

Searching for Abilities/Actions, rather than just the whole text of the card: when I look for "terrifying" I'm not usually also looking for everything with Ruthless. Perhaps this could use the same sort of "tag" as icons, like putting a colon in front or something.

These first 2 would, I think, have issues with metadata size, but I'm not really sure.

Last, and also least, the ability to share and then import collections as guest collections/users. E.g. someone on the forum has X models and would like crew building advice, I could then just import the linked list as a guest collection and build using only those models.

Overall, great app, thanks for all your work.

Share this post


Link to post
Share on other sites
On 9/29/2019 at 6:39 AM, CustardBomb said:

Both me and my opponent had an issue at seperate times when running a game via the app. When trying to view cars in our crew through the game menu not the crew menu we would only get this screen. 

Restarting the app and rejoining the game does not help. 

 

In a separate instance I was not able to record HP loss on the app. After applying the damage a few seconds later the app would refill the health to full. 

 

Screenshot_20190929-213432.jpg

As a followup, this should be addressed in 1.0.5, which is out on Android. iOS is pending resolution of auth issues as I transfer ownership of the app to Wyrd.

Share this post


Link to post
Share on other sites

Filter issue. Cannot filter for “Heal”. Because Health is on every card and filter cannot do exact string matching.

Don’t know how to get around this other than to not have the word Health be searchable on the card. 

Hopefully we will be able to filter for such healing effects. 

  • Agree 1

Share this post


Link to post
Share on other sites
1 hour ago, AndreyF said:

"Download all" does not download all  cards. Upgrades are missing, some model cards too.

Which cards?

Also I don't know if this is an answer to your issue, but upgrades are not listed with models. There is a tab selection for model and upgrade cards. Hope that helps.

Share this post


Link to post
Share on other sites

Suggestion: When you are playing a game and you are summoning using the reference cards. You can change which card it is by clicking on the name and using the dropdown but when you go back to the main screen to add the card it just has the base name and not the number. When you add the card it shows the number in your list. If it showed the number on the list you could remember which model to add to the table.

Also I noticed if say you have witchling stalker and witchling stalker 3 in your list and you add a 3rd and final one. It doesn't by default add witchling stalker 2. Not many people have more than 1 of the exact same models so it would be nice if it did it automatically (though not as easy for cards that have lots of alts).

Share this post


Link to post
Share on other sites
9 hours ago, Morgan Vening said:

I'll suggest adding a news item (in the News section) for a changelog for every update.

Just had the program update (~12mb IIRC), and don't know what bugs were fixed, or if any new features have been added.

The changes for each version are listed in full on the app stores respective pages

Share this post


Link to post
Share on other sites

hope this is the right topic but...

will we got an update for TOS?

it'll be very cool to got a tos crew builde, suppose it is not hard to add cards and other stff to the already existing app

Share this post


Link to post
Share on other sites
11 hours ago, Champignon said:

hope this is the right topic but...

will we got an update for TOS?

it'll be very cool to got a tos crew builde, suppose it is not hard to add cards and other stff to the already existing app

TOS is not going to be incorporated into the existing app.

Wyrd has said the first TOS app they commissioned ended up not meeting their expectations, so they discontinued it. They will release a standalone TOS app as soon as they have one that is up to their standards.

  • Thanks 1

Share this post


Link to post
Share on other sites
6 hours ago, Shadrack said:

For the last couple of days I have constantly gotten the below error when I try to browse cards.

Screenshot_20191004-233837.png

Don’t forget to state what phone and what app version you have   App version is found in Settings. 

 

Share this post


Link to post
Share on other sites
8 hours ago, Artiee said:

Don’t forget to state what phone and what app version you have   App version is found in Settings. 

 

Sorry about leveling that off. I am on a Moto 4x (Android) and the version number is 1.0.5. The play store says there is no update atm.

Also found that I get errors for games and crews as well.

 

Screenshot_20191005-144153.png

Screenshot_20191005-144201.png

Edited by Shadrack
Adding information.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information