Jump to content
Sign in to follow this  
Go Canucks Go

Compatible Books

Recommended Posts

31 minutes ago, Go Canucks Go said:

Oh Ok I thought those books were out before the new core rules. thanks

Under Quarantine, Into the Bayou, and Into the Steam are pre-2nd Edition. Above the Law is post-2nd Ed, but all of them are compatible. The Penny Dreadfuls are both pre- and post 2nd Ed as well. The Core Rules book outlines what to change when running with pre-2nd Ed stuff. 

 

Hope this helps!

Share this post


Link to post
Share on other sites

The biggest potential issues are probably with some of the weapons and occasionally suits on magic. Off the top of my head, keep an eye on the Into the Steam weapons and check them against the new corebook, and take a look at suits on spells. For the most part, the new corebook magic pursuits and magia assumes that all Sorcery uses tomes, Necromancy uses crows, etc, and some stuff from the older books (Gremlin bokur, IIRC) need to be tweaked so they work with the update. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...